## 开始页面 当您第一次打开 GameMaker Studio 2 时,您将被要求登录到您的YoYo帐户(如果您还没有账户,请注册一个)。 一旦注册并登录, 整个软件的主要部分 GameMaker Studio 2 IDE 将启动一个开始页面: ![](https://lh6.googleusercontent.com/zppVF-Q3KCCmVIjh09csLW8c2ZQjRynOiKHUFkS8E5blthuJNZzKO2ZuXOVpfo05HjsvQsg3QatMW03v3Xj2qUOujXNpf34GkeXSQPAUpjF1IghtK7PTMVq4tNT97Q54kNLcb391) 在顶部,您可以找到 IDE 通用菜单,这些菜单在本手册的以下部分中进行说明: * 文件菜单 * 编辑菜单 * 构建菜单 * Windows菜单 * 工具菜单 * 市场菜单 * 帮助菜单 * 布局菜单 请注意,顶部菜单栏中还会显示一些特定的菜单选项,具体显示项取决于您当前聚焦的窗口。 例如,如果您当前聚焦于资源树窗口,那么将会为“资源”显示一个额外的菜单项。 起始页的其余内容将在以下部分解释: ### 主页 当浏览起始页的不同部分时,单击鼠标左键此处将快速地返回到主页面。 最近项目 在开始页面左侧,您可以看到之前打开的项目列表。 如果您将鼠标悬停其上,则可以看到完整的项目名称和路径,单击鼠标左键将打开该项目。 ### 社交 起始页面的顶部栏包含许多链接,使导航更便捷。 如下所示: * 我的帐户 - 登录您的YoYo帐户(详情请参阅这里) * YoYo游戏 - 转到YoYo游戏的主网站 * 社交媒体图标 - 点击这些图标将带您到YoYo Games的各个社交媒体网站主页,您可以随时了解有关 GameMaker Studio 2 的新闻 ### 项目 在“项目”部分中可以创建,打开或导入项目。 您可以单击新建以创建新项目,点击打开以打开现有项目或打开导入的 GameMaker:Studio 1.4 GMX 项目文件以及打开压缩的 YYZ 格式的GameMaker Studio 2 项目文件。 打开和导入动作将会打开文件浏览器,以便浏览到所需的项目文件。 注意:GameMaker Studio 2 并不完全向后兼容 GameMaker:Studio 1.4 项目,但导入的1.4项目仍可运行,因为已自动使用兼容性脚本重新构建了过时功能。 有关可能出现的问题和对GML 所做更改的详细信息,请参阅帮助中心文章“将GMS 1.4项目移植到 GameMaker Studio 2”部分以及“过时功能手册”部分。 要创建一个新项目,只需点击标有“新建”的按钮,即可进入以下图片所示界面: ![](https://lh5.googleusercontent.com/maIN_QEVBODbEP981tM62JN8B1OAOtGN_j9Y-ij66YMkvBkOZSlM4adnbqrqEuQj7MK-u6KD3SYCzYPSecbK6aSPdnoYrG2M0yzYZhkSJNRMG4_Ev2Qn5i8NfM727lcnaV5bI0uu) GameMaker Studio 2允许您指定要创建的项目类型,您可以根据对编程的了解以及自己的习惯进行选择。可用的选项有: * 新的拖放项目:将会创建一个新项目,并设置对象编辑器(以及其他代码编辑器)以使用 GameMaker Studio 2 拖放界面。有关拖放(DnD™)的更多信息,请参见此处。请注意,这不是唯一的DnD™开启方法,您可以使用鼠标右键在DnD™和GML代码之间进行切换。 * 新的 GML 项目:这将创建一个使用 GameMaker 语言(GML)为默认编程语言的项目。您可以在这里找到有关 GML 的更多信息。请注意,这不是唯一的 GML 开启方法,您可以使用鼠标右键在GML代码和DnD™之间切换。 无论您选择什么,系统都会提示您选择项目的保存位置,然后在 GameMaker Studio 2 中打开新建的项目。 ### 信息 开始页面的信息部分允许您浏览 YoYo 游戏市场,浏览并打开 YoYo Games 团队制作的教程和演示,以展示GameMaker Studio 2的具体内容(详情请见下文)。 ### 教程和演示 当您点击“教程”或“演示”按钮时,您将进入一个界面,其中显示您拥有的教程/演示以及可供下载的官方教程/演示: ![](https://lh4.googleusercontent.com/DESWqll-J4h0iG5keppDLKtbTSdZdW02fzqxaSa9TfgVotvqEjH4XpiceYrzAqusIep66HVGeDfrw4sZUXCEfxV133eeq1xpSk4rqZ4WrXD9Lj7CZKmD4WzSrLKwicnfUjisxeyL) 要下载任何官方教程或演示文稿,您只需点击您想要浏览的内容的图标,并将其添加到上方的“拥有”栏内(请注意,您可能需要在此之前先登录市场)。 一旦教程或演示出现在“拥有”栏内,您就可以将鼠标悬停在其上,选择安装它或从查看其市场信息: ![](https://lh3.googleusercontent.com/i6UCB7JMsJ7kMQ7fBki3BTSviZMlYDF8JgAj4xVGmO0jS9h6E5vPORJQD_om1MilTEdQeiQ9bKIlMXCxUWRLo_0Q093JCUMmlvGx_TLvgUyjABC3o7vDQzgbzxqUwxMp0IU12sIs) 安装教程或演示后,您只需单击它即可将其打开,您将被提示选择一个位置来保存教程项目,然后才能在 IDE 中开始。 请注意,安装的教程和演示将有一个额外的图标,用于从计算机中卸载项目(此操作不会从您的“拥有”列表中删除教程或演示)。 起始页面的教程/演示部分还有几个按钮可帮助您更好地使用以及引导资源: ![](https://lh3.googleusercontent.com/QaX9lqNM5LIzRoUK1_0MNa9UpCcGnSD7o_LkfVtG_56pQ3NY4rshJG_Jtd3bjT_0gI68PR0UmM-PgOqc-iS7TNsTYb5ZG_9-YqJVsj9Klc5hT_2EK2RwSA8hDrViGQab7M4508IM) 单击此项将从市场刷新项目列表,以便您查看是否有更新并获取最新版本。 ![](https://lh5.googleusercontent.com/ADykKKC2YmqcsJHD1MYEcQdo42WKJeficOV08dQsdojsLLVc-bv77vT663Q27_CrYKZvUkT7V5ydUrtEO_Dcl_f0_0IPSrBrrLD2bc40sBsxDgnLbiUoRCpZG6751tKqbNp0q3sa) 单击此项可以在您所拥有的教程和演示文稿以及您已安装的教程和演示之间切换视图。 请注意,通过教程,您可以随时保存项目并关闭 IDE,甚至更改项目,而不用担心丢失某些东西,因为教程将存储您每次保存项目时正在处理的页面和内容。 同样值得一提的是,您也可以从市场中找到第三方教程和演示文稿,一旦这些教程和演示文稿已被购买并添加到您的帐户中,他们也将出现在相应页面的“拥有”栏中。